UnratedPackagistPublished
Laravel Encrypter Failure to decryption vulnerability
GHSA-6wjw-qf87-fv5v
- Affected
- Packagist illuminate/encryption >= 5.5.0, < 5.5.40; >= 5.6.0, < 5.6.15
- Fixed in
- 5.5.405.6.15· Vendor fix available
- Issue
- A potential exploit of the Laravel Encrypter component that may cause the Encrypter to fail on decryption and unexpectedly return false. To exploit this, the attacker must be able to modify the encrypted payload before it is decrypted. Depending on the code within your application, this could lead to unexpected behavior when combined with weak type comparisons, for example:
Recommended action: Upgrade to 5.6.15 or 5.5.40 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.