Laravel Encrypter Failure to decryption vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (illuminate/encryption 5.6.15, 5.5.40), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist illuminate/encryption
- Affected
- >= 5.5.0, < 5.5.40>= 5.6.0, < 5.6.15
- Fixed in
- 5.5.40, 5.6.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6wjw-qf87-fv5v lists affected ranges: Packagist illuminate/encryption >=5.5.0 =5.6.0 <5.6.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
A potential exploit of the Laravel Encrypter component that may cause the Encrypter to fail on decryption and unexpectedly return false. To exploit this, the attacker must be able to modify the encrypted payload before it is decrypted. Depending on the code within your application, this could lead to unexpected behavior when combined with weak type comparisons, for example:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6wjw-qf87-fv5v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-6wjw-qf87-fv5v Advisory: Laravel Encrypter Failure to decryption vulnerability IDs: GHSA-6wjw-qf87-fv5v Record: https://patchnext.com/advisories/ghsa-6wjw-qf87-fv5v (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: illuminate/encryption 5.6.15, 5.5.40. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist illuminate/encryption: affected >= 5.5.0, < 5.5.40; >= 5.6.0, < 5.6.15; fixed in 5.5.40, 5.6.15 ## Suggested inspection (read-only) - Packagist illuminate/encryption: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on illuminate/encryption. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6wjw-qf87-fv5v (GitHub-reviewed advisory GHSA-6wjw-qf87-fv5v lists affected ranges: Packagist illuminate/encryption >=5.5.0 =5.6.0 <5.6.15) Commands are suggestions: review each one before running it.
Loading voting…