Skip to content

← Public intelligence

Packagist package

ibexa/admin-ui

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.8PackagistPublished

    ibexa/admin-ui has an XSS vulnerability in Cancel/Reschedule future publication modal

    GHSA-2mx6-fq24-g2mh

    Affected
    • Packagist ibexa/admin-ui >= 5.0.0, < 5.0.3; >= 4.6.0, < 4.6.25
    Fixed in
    4.6.255.0.3· Vendor fix available
    Issue
    Impact This security advisory resolves an XSS vulnerability in image asset names, content language names and future publishing in the back office of the DXP. Back office access and varying levels of editing and management permissions are required to exploit this vulnerability. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and may in some cases be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless. Patches See "Patched versions". Workarounds None. References https://developers.ibexa.co/security-advisories/ibexa-sa-2025-004-xss-and-enumeration-vulnerabilities-in-back-office

    Recommended action: Upgrade to 5.0.3 or 4.6.25 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.1PackagistPublished

    Ibexa Admin UI XSS vulnerabilities in back office

    GHSA-5r6x-g6jv-4v87

    Affected
    • Packagist ibexa/admin-ui >= 4.6.0-beta1, < 4.6.21
    Fixed in
    4.6.21· Vendor fix available
    Issue
    Impact This security advisory is a part of IBEXA-SA-2025-003, which resolves XSS vulnerabilities in several parts of the back office of Ibexa DXP. Back office access and varying levels of editing and management permissions are required to exploit these vulnerabilities. This typically means Editor or Administrator role, or similar. Injected XSS is persistent and can be reflected in the front office, possibly affecting end users. The fixes ensure XSS is escaped, and any existing injected XSS is rendered harmless. Patches - See "Patched versions". - https://github.com/ibexa/admin-ui/commit/72a64d90d249e5f4c4a5e8238f5d627c9b68d9b8 Workarounds None.

    Recommended action: Upgrade to 4.6.21 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3PackagistPublished

    Ibexa Admin UI vulnerable to Cross-site Scripting in a field that is used in the Content name pattern

    CVE-2024-53864 · GHSA-8w3p-gf85-qcch

    Affected
    • Packagist ibexa/admin-ui >= 4.6.0, < 4.6.14
    Fixed in
    4.6.14· Vendor fix available
    Issue
    Impact The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it. After the fix, any existing injected XSS will not run. Patches - See "Patched versions. - https://github.com/ibexa/admin-ui/commit/8ec824a8cf06c566ed88e4c21cc66f7ed42649fc Workarounds None. References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes: https://doc.ibexa.co/en/latest/updateandmigration/from4.6/updatefrom4.6/#v4614

    Recommended action: Upgrade to 4.6.14 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 4.8PackagistPublished

    Ibexa Admin UI vulnerable to DOM-based Cross-site Scripting in file upload widget

    CVE-2024-39318 · GHSA-qm44-wjm2-pr59

    Affected
    • Packagist ibexa/admin-ui >= 4.6.0-beta1, < 4.6.9
    Fixed in
    4.6.9· Vendor fix available
    Issue
    Impact The file upload widget is vulnerable to XSS payloads in filenames. Access permission to upload files is required. As such, in most cases only authenticated editors and administrators will have the required permission. It is not persistent, i.e. the payload is only executed during the upload. In effect, an attacker will have to trick an editor/administrator into uploading a strangely named file. The fix ensures XSS is escaped. Patches See "Patched versions". Commit: https://github.com/ibexa/admin-ui/commit/8dc413fad1045fcfbe65dbcb0bea8516accc4c3e Workarounds None. References - https://developers.ibexa.co/security-advisories/ibexa-sa-2024-004-dom-based-xss-in-file-upload - https://github.com/ibexa/admin-ui/commit/8dc413fad1045fcfbe65dbcb0bea8516accc4c3e - https://github.com/ezsystems/ezplatform-admin-ui/security/advisories/GHSA-gc5h-6jx9-q2qh Credit This vulnerability was discovered and reported to Ibexa by Alec Romano: https://github.com/4rdr We thank them for reporting it…

    Recommended action: Upgrade to 4.6.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. UnratedPackagistPublished

    Ibexa DXP users with the Company admin role can assign any role to any user

    GHSA-g6jc-xrc3-4wwq

    Affected
    • Packagist ibexa/admin-ui >= 4.2.0, < 4.2.3
    Fixed in
    4.2.3· Vendor fix available
    Issue
    Critical severity. Users with the Company admin role (introduced by the company account feature in v4) can assign any role to any user. This also applies to any other user that has the role / assign policy. Any subtree limitation in place does not have any effect. The role / assign policy is typically only given to administrators, which limits the scope in most cases, but please verify who has this policy in your installaton. The fix ensures that subtree limitations are working as intended.

    Recommended action: Upgrade to 4.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. UnratedPackagistPublished

    ibexa/admin-ui vulnerable to Cross-site Scripting in content type name/shortname

    GHSA-7644-cxp8-h23r

    Affected
    • Packagist ibexa/admin-ui >= 4.2.0, < 4.2.3
    Fixed in
    4.2.3· Vendor fix available
    Issue
    Critical severity. It is possible to inject JavaScript XSS in the content type entries "name" and "short name". To exploit this, one must already have permission to edit content types, which limits it in many cases to people who are already administrators. However, please verify which users have this permission. The fix ensures any injections are escaped.

    Recommended action: Upgrade to 4.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →