Ibexa Admin UI vulnerable to Cross-site Scripting in a field that is used in the Content name pattern
CVE-2024-53864GHSA-8w3p-gf85-qcch
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ibexa/admin-ui 4.6.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ibexa/admin-ui
- Affected
- >= 4.6.0, < 4.6.14
- Fixed in
- 4.6.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8w3p-gf85-qcch lists affected ranges: Packagist ibexa/admin-ui >=4.6.0 <4.6.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X · score source
- EPSS
- CVE-2024-53864: 0.53% estimated exploitation activity in the next 30 days; percentile 45.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Content name pattern is used to build Content names from one or more fields. An XSS vulnerability has been found in this mechanism. Content edit permission is required to exploit it. After the fix, any existing injected XSS will not run. Patches - See "Patched versions. - https://github.com/ibexa/admin-ui/commit/8ec824a8cf06c566ed88e4c21cc66f7ed42649fc Workarounds None. References - Advisory: https://developers.ibexa.co/security-advisories/ibexa-sa-2024-006-vulnerabilities-in-content-name-pattern-commerce-shop-and-varnish-vhost-templates - Release notes: https://doc.ibexa.co/en/latest/updateandmigration/from4.6/updatefrom4.6/#v4614
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8w3p-gf85-qcch
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-53864 Advisory: Ibexa Admin UI vulnerable to Cross-site Scripting in a field that is used in the Content name pattern IDs: CVE-2024-53864, GHSA-8w3p-gf85-qcch Record: https://patchnext.com/advisories/cve-2024-53864 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ibexa/admin-ui 4.6.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ibexa/admin-ui: affected >= 4.6.0, < 4.6.14; fixed in 4.6.14 ## Suggested inspection (read-only) - Packagist ibexa/admin-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ibexa/admin-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8w3p-gf85-qcch (GitHub-reviewed advisory GHSA-8w3p-gf85-qcch lists affected ranges: Packagist ibexa/admin-ui >=4.6.0 <4.6.14) Commands are suggestions: review each one before running it.
Loading voting…