Medium, CVSS 6.3PackagistPublished
Guzzle OAuth Subscriber has insufficient nonce entropy
CVE-2025-21617 · GHSA-237r-r8m4-4q88
- Affected
- Packagist guzzlehttp/oauth-subscriber < 0.8.1
- Fixed in
- 0.8.1· Vendor fix available
- Issue
- Impact Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used. Patches Upgrade to version 0.8.1 or higher. Workarounds No. References Issue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.
Recommended action: Upgrade to 0.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.