Guzzle OAuth Subscriber has insufficient nonce entropy
CVE-2025-21617GHSA-237r-r8m4-4q88
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (guzzlehttp/oauth-subscriber 0.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist guzzlehttp/oauth-subscriber
- Affected
- < 0.8.1
- Fixed in
- 0.8.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-237r-r8m4-4q88 lists affected ranges: Packagist guzzlehttp/oauth-subscriber >=0 <0.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-21617: 0.48% estimated exploitation activity in the next 30 days; percentile 41.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Nonce generation does not use sufficient entropy nor a cryptographically secure pseudorandom source (https://github.com/guzzle/oauth-subscriber/blob/0.8.0/src/Oauth1.php#L192). This can leave servers vulnerable to replay attacks when TLS is not used. Patches Upgrade to version 0.8.1 or higher. Workarounds No. References Issue is similar to https://nvd.nist.gov/vuln/detail/CVE-2025-22376.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-237r-r8m4-4q88
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-21617 Advisory: Guzzle OAuth Subscriber has insufficient nonce entropy IDs: CVE-2025-21617, GHSA-237r-r8m4-4q88 Record: https://patchnext.com/advisories/cve-2025-21617 (revision 1, source checked 26 Oct 2026, 14:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: guzzlehttp/oauth-subscriber 0.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist guzzlehttp/oauth-subscriber: affected < 0.8.1; fixed in 0.8.1 ## Suggested inspection (read-only) - Packagist guzzlehttp/oauth-subscriber: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on guzzlehttp/oauth-subscriber. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-237r-r8m4-4q88 (GitHub-reviewed advisory GHSA-237r-r8m4-4q88 lists affected ranges: Packagist guzzlehttp/oauth-subscriber >=0 <0.8.1) Commands are suggestions: review each one before running it.
Loading voting…