Skip to content

← Public intelligence

Packagist package

goalgorilla/open_social

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.8PackagistPublished

    Drupal Open Social Missing Authorization vulnerability

    CVE-2025-31685 · GHSA-gf72-h4cp-wcm4

    Affected
    • Packagist goalgorilla/open_social < 12.3.11; >= 12.4.0, < 12.4.10
    Fixed in
    12.3.1112.4.10· Vendor fix available
    Issue
    Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing. This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.

    Recommended action: Upgrade to 12.4.10 or 12.3.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.2PackagistPublished

    Drupal Open Social Missing Authorization vulnerability

    CVE-2025-31686 · GHSA-m9w8-wxvp-c9gv

    Affected
    • Packagist goalgorilla/open_social < 12.3.11; >= 12.4.0, < 12.4.10
    Fixed in
    12.3.1112.4.10· Vendor fix available
    Issue
    Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing. This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.

    Recommended action: Upgrade to 12.4.10 or 12.3.11 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 5.3PackagistPublished

    Drupal Open Social allows Functionality Misuse

    CVE-2024-13274 · GHSA-63wg-87qv-rw4r

    Affected
    • Packagist goalgorilla/open_social < 12.3.8; >= 12.4.0, < 12.4.5; >= 13.0.0-alpha1, < 13.0.0-alpha11
    Fixed in
    12.3.812.4.513.0.0-alpha11· Vendor fix available
    Issue
    The distribution didn't validate the flood control limits on the password reset form correctly resulting in a potential attacker flooding the password reset which could result in a Denial of Service. Fortunately the message does not disclose any information to the attacker.

    Recommended action: Upgrade to 13.0.0-alpha11 (pre-release), 12.4.5 or 12.3.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →