Drupal Open Social Missing Authorization vulnerability
CVE-2025-31686GHSA-m9w8-wxvp-c9gv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (goalgorilla/open_social 12.4.10, 12.3.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist goalgorilla/open_social
- Affected
- < 12.3.11>= 12.4.0, < 12.4.10
- Fixed in
- 12.3.11, 12.4.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m9w8-wxvp-c9gv lists affected ranges: Packagist goalgorilla/open_social >=0 =12.4.0 <12.4.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-31686: 0.41% estimated exploitation activity in the next 30 days; percentile 35.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Missing Authorization vulnerability in Drupal Open Social allows Forceful Browsing. This issue affects Open Social: from 0.0.0 before 12.3.11, from 12.4.0 before 12.4.10.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m9w8-wxvp-c9gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31686 Advisory: Drupal Open Social Missing Authorization vulnerability IDs: CVE-2025-31686, GHSA-m9w8-wxvp-c9gv Record: https://patchnext.com/advisories/cve-2025-31686 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: goalgorilla/open_social 12.4.10, 12.3.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist goalgorilla/open_social: affected < 12.3.11; >= 12.4.0, < 12.4.10; fixed in 12.3.11, 12.4.10 ## Suggested inspection (read-only) - Packagist goalgorilla/open_social: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on goalgorilla/open_social. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m9w8-wxvp-c9gv (GitHub-reviewed advisory GHSA-m9w8-wxvp-c9gv lists affected ranges: Packagist goalgorilla/open_social >=0 =12.4.0 <12.4.10) Commands are suggestions: review each one before running it.
Loading voting…