Skip to content

← Public intelligence

Packagist package

getkirby/kirby

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3PackagistPublished

    Kirby vulnerable to path traversal of snippet names in the snippet() helper

    CVE-2025-30159 · GHSA-fw82-87p8-v6hp

    Affected
    • Packagist getkirby/kirby < 3.9.8.3; >= 3.10.0, < 3.10.1.2; >= 4.0.0, < 4.7.1
    Fixed in
    4.7.13.9.8.33.10.1.2· Vendor fix available
    Issue
    TL;DR This vulnerability affects all Kirby sites that use the snippet() helper or $kirby-snippet() method with a dynamic snippet name (such as a snippet name that depends on request or user data). Sites that only use fixed calls to the snippet() helper/$kirby-snippet() method (i.e. calls with a simple string for the snippet name) are not affected. ---- Introduction Kirby's snippet() helper and $kirby-snippet() method (in the following abbreviated to the snippet() helper) allow to load PHP snippet files that are normally stored in the site/snippets folder or registered by plugins through the snippets plugin extension. If the snippet() helper is called with an arbitrary snippet name, Kirby first checks if a file with this name exists in the snippets root (which defaults to site/snippets). This logic was vulnerable against path traversal attacks. By using special elements such as .. and / separators, attackers can escape outside of the restricted location to access files or directories…

    Recommended action: Upgrade to 4.7.1, 3.10.1.2 or 3.9.8.3 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →