Skip to content

← Actionable
Medium, CVSS 6.3

Kirby vulnerable to path traversal of snippet names in the snippet() helper

CVE-2025-30159GHSA-fw82-87p8-v6hp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/kirby 4.7.1, 3.10.1.2, 3.9.8.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getkirby/kirby

    Affected
    < 3.9.8.3>= 3.10.0, < 3.10.1.2>= 4.0.0, < 4.7.1
    Fixed in
    4.7.1, 3.9.8.3, 3.10.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2025-30159: 0.71% estimated exploitation activity in the next 30 days; percentile 53.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

TL;DR This vulnerability affects all Kirby sites that use the snippet() helper or $kirby-snippet() method with a dynamic snippet name (such as a snippet name that depends on request or user data). Sites that only use fixed calls to the snippet() helper/$kirby-snippet() method (i.e. calls with a simple string for the snippet name) are not affected. ---- Introduction Kirby's snippet() helper and $kirby-snippet() method (in the following abbreviated to the snippet() helper) allow to load PHP snippet files that are normally stored in the site/snippets folder or registered by plugins through the snippets plugin extension. If the snippet() helper is called with an arbitrary snippet name, Kirby first checks if a file with this name exists in the snippets root (which defaults to site/snippets). This logic was vulnerable against path traversal attacks. By using special elements such as .. and / separators, attackers can escape outside of the restricted location to access files or directories…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fw82-87p8-v6hp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-30159

Advisory: Kirby vulnerable to path traversal of snippet names in the `snippet()` helper
IDs: CVE-2025-30159, GHSA-fw82-87p8-v6hp
Record: https://patchnext.com/advisories/cve-2025-30159 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: getkirby/kirby 4.7.1, 3.10.1.2, 3.9.8.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getkirby/kirby: affected < 3.9.8.3; >= 3.10.0, < 3.10.1.2; >= 4.0.0, < 4.7.1; fixed in 4.7.1, 3.9.8.3, 3.10.1.2

## Suggested inspection (read-only)
- Packagist getkirby/kirby: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getkirby/kirby.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fw82-87p8-v6hp (GitHub-reviewed advisory GHSA-fw82-87p8-v6hp lists affected ranges: Packagist getkirby/kirby >=0 =3.10.0 =4.0.0 <4.7.1)

Commands are suggestions: review each one before running it.

Loading voting…