Low, CVSS 3.5PackagistPublished
Magnesium-PHP Injection vulnerability
CVE-2017-20187 · GHSA-8pp6-5qpw-85g3
- Affected
- Packagist floriangaerber/magnesium < 0.3.1
- Fixed in
- 0.3.1· Vendor fix available
- Issue
- UNSUPPORTED WHEN ASSIGNED UNSUPPORTED WHEN ASSIGNED A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Recommended action: Upgrade to 0.3.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.