Skip to content

← Actionable
Low, CVSS 3.5

Magnesium-PHP Injection vulnerability

CVE-2017-20187GHSA-8pp6-5qpw-85g3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (floriangaerber/magnesium 0.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.0/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2017-20187: 0.69% estimated exploitation activity in the next 30 days; percentile 52.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

UNSUPPORTED WHEN ASSIGNED UNSUPPORTED WHEN ASSIGNED A vulnerability was found in Magnesium-PHP up to 0.3.0. It has been classified as problematic. Affected is the function formatEmailString of the file src/Magnesium/Message/Base.php. The manipulation of the argument email/name leads to injection. Upgrading to version 0.3.1 is able to address this issue. The patch is identified as 500d340e1f6421007413cc08a8383475221c2604. It is recommended to upgrade the affected component. VDB-244482 is the identifier assigned to this vulnerability. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8pp6-5qpw-85g3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2017-20187

Advisory: Magnesium-PHP Injection vulnerability
IDs: CVE-2017-20187, GHSA-8pp6-5qpw-85g3
Record: https://patchnext.com/advisories/cve-2017-20187 (revision 1, source checked 26 Oct 2026, 14:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: floriangaerber/magnesium 0.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist floriangaerber/magnesium: affected < 0.3.1; fixed in 0.3.1

## Suggested inspection (read-only)
- Packagist floriangaerber/magnesium: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on floriangaerber/magnesium.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8pp6-5qpw-85g3 (GitHub-reviewed advisory GHSA-8pp6-5qpw-85g3 lists affected ranges: Packagist floriangaerber/magnesium >=0 <0.3.1)

Commands are suggestions: review each one before running it.

Loading voting…