Skip to content

← Public intelligence

Packagist package

firebase/php-jwt

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Low, CVSS 2.7PackagistPublished

    php-jwt contains weak encryption

    CVE-2025-45769 · GHSA-2x45-7fc3-mxwq

    Affected
    • Packagist firebase/php-jwt < 7.0.0
    Fixed in
    7.0.0· Vendor fix available
    Issue
    php-jwt v6.11.0 was discovered to contain weak encryption.

    Recommended action: Upgrade to 7.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. UnratedPackagistPublished

    firebase/php-jwt: "None" Algorithm treated as valid on tokens

    GHSA-h533-5v22-8vcp

    Affected
    • Packagist firebase/php-jwt < 2.0.0
    Fixed in
    2.0.0· Vendor fix available
    Issue
    Several widely-used JSON Web Token (JWT) libraries, including node-jsonwebtoken, pyjwt, namshi/jose, php-jwt, and jsjwt, are affected by critical vulnerabilities that could allow attackers to bypass the verification step when using asymmetric keys (RS256, RS384, RS512, ES256, ES384, ES512).

    Recommended action: Upgrade to 2.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.1PackagistPublished

    Firebase PHP-JWT key/algorithm type confusion

    CVE-2021-46743 · GHSA-8xf4-w7qw-pjjw

    Affected
    • Packagist firebase/php-jwt < 6.0.0
    Fixed in
    6.0.0· Vendor fix available
    Issue
    In Firebase PHP-JWT before 6.0.0, an algorithm-confusion issue (e.g., RS256 / HS256) exists via the kid (aka Key ID) header, when multiple types of keys are loaded in a key ring. This allows an attacker to forge tokens that validate under the incorrect key. NOTE: this provides a straightforward way to use the PHP-JWT library unsafely, but might not be considered a vulnerability in the library itself.

    Recommended action: Upgrade to 6.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →