Firebase PHP-JWT key/algorithm type confusion
CVE-2021-46743GHSA-8xf4-w7qw-pjjw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (firebase/php-jwt 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist firebase/php-jwt
- Affected
- < 6.0.0
- Fixed in
- 6.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xf4-w7qw-pjjw lists affected ranges: Packagist firebase/php-jwt >=0 <6.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2021-46743: 0.92% estimated exploitation activity in the next 30 days; percentile 60.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Firebase PHP-JWT before 6.0.0, an algorithm-confusion issue (e.g., RS256 / HS256) exists via the kid (aka Key ID) header, when multiple types of keys are loaded in a key ring. This allows an attacker to forge tokens that validate under the incorrect key. NOTE: this provides a straightforward way to use the PHP-JWT library unsafely, but might not be considered a vulnerability in the library itself.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8xf4-w7qw-pjjw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-46743 Advisory: Firebase PHP-JWT key/algorithm type confusion IDs: CVE-2021-46743, GHSA-8xf4-w7qw-pjjw Record: https://patchnext.com/advisories/cve-2021-46743 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: firebase/php-jwt 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist firebase/php-jwt: affected < 6.0.0; fixed in 6.0.0 ## Suggested inspection (read-only) - Packagist firebase/php-jwt: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on firebase/php-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8xf4-w7qw-pjjw (GitHub-reviewed advisory GHSA-8xf4-w7qw-pjjw lists affected ranges: Packagist firebase/php-jwt >=0 <6.0.0) Commands are suggestions: review each one before running it.
Loading voting…