Skip to content

← Public intelligence

Packagist package

facade/ignition

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Critical, CVSS 9.8PackagistPublished

    Incorrect Access Control in Ignition

    CVE-2021-43996 · GHSA-vhrp-8qx4-vr6c

    Affected
    • Packagist facade/ignition < 1.16.15; >= 2.0.0, < 2.0.6
    Fixed in
    1.16.152.0.6· Vendor fix available
    Issue
    The Ignition component before 1.16.15, and 2.0.x before 2.0.6, for Laravel has a "fix variable names" feature that can lead to incorrect access control.

    Recommended action: Upgrade to 2.0.6 or 1.16.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    Critical severity vulnerability in Ignition

    CVE-2020-13909 · GHSA-m5v7-pr32-mjx2

    Affected
    • Packagist facade/ignition >= 2.0.0, < 2.0.5; < 1.16.15
    Fixed in
    1.16.152.0.5· Vendor fix available
    Issue
    The Ignition page before version 2.0.5 for Laravel mishandles globals, get, post, cookie, and env. NOTE: in the 1.x series, versions 1.16.15 and later are unaffected as a consequence of the CVE-2021-43996 fix.

    Recommended action: Upgrade to 2.0.5 or 1.16.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Critical, CVSS 9.8Exploited · CISA KEVPackagistPublished

    Unauthenticated remote code execution in Ignition

    CVE-2021-3129 · GHSA-4qwp-7c67-jmcc

    Affected
    • Packagist facade/ignition >= 2.5.0, < 2.5.2; >= 2.0.0, < 2.4.2; >= 1.7.0, < 1.16.14; < 1.6.15
    Fixed in
    2.4.22.5.21.6.151.16.14· Vendor fix available
    Issue
    Ignition before 2.5.2, as used in Laravel and other products, allows unauthenticated remote attackers to execute arbitrary code because of insecure usage of filegetcontents() and fileputcontents(). This is exploitable on sites using debug mode with Laravel before 8.4.2.

    Recommended action: Upgrade to 2.5.2, 2.4.2, 1.16.14 or 1.6.15 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:cisa.gov (1)github.com (2)Source checked Evidence →