Critical severity vulnerability in Ignition
CVE-2020-13909GHSA-m5v7-pr32-mjx2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (facade/ignition 2.0.5, 1.16.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist facade/ignition
- Affected
- >= 2.0.0, < 2.0.5< 1.16.15
- Fixed in
- 1.16.15, 2.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m5v7-pr32-mjx2 lists affected ranges: Packagist facade/ignition >=2.0.0 =0 <1.16.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-13909: 1.52% estimated exploitation activity in the next 30 days; percentile 74.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Ignition page before version 2.0.5 for Laravel mishandles globals, get, post, cookie, and env. NOTE: in the 1.x series, versions 1.16.15 and later are unaffected as a consequence of the CVE-2021-43996 fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-m5v7-pr32-mjx2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-13909 Advisory: Critical severity vulnerability in Ignition IDs: CVE-2020-13909, GHSA-m5v7-pr32-mjx2 Record: https://patchnext.com/advisories/cve-2020-13909 (revision 1, source checked 26 Oct 2026, 14:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: facade/ignition 2.0.5, 1.16.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist facade/ignition: affected >= 2.0.0, < 2.0.5; < 1.16.15; fixed in 1.16.15, 2.0.5 ## Suggested inspection (read-only) - Packagist facade/ignition: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on facade/ignition. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-m5v7-pr32-mjx2 (GitHub-reviewed advisory GHSA-m5v7-pr32-mjx2 lists affected ranges: Packagist facade/ignition >=2.0.0 =0 <1.16.15) Commands are suggestions: review each one before running it.
Loading voting…