Skip to content

← Public intelligence

Packagist package

ezsystems/ezplatform-solr-search-engine

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. UnratedPackagistPublished

    Json response for search reveals Solr credentials

    GHSA-7crc-r3wg-cfgf

    Affected
    • Packagist ezsystems/ezplatform-solr-search-engine >= 3.3.0, < 3.3.15; >= 2.0.0, < 2.0.2; >= 1.7.0, < 1.7.12
    Fixed in
    3.3.151.7.122.0.2· Vendor fix available
    Issue
    Impact An error in Ibexa's Solr search engine results in potential exposure of Solr credentials. This is a critical vulnerability and all supported versions of the engine are affected. Those not using the Solr search engine are not affected. Patches The issue is fixed in all supported versions of ezsystems/ezplatform-solr-search-engine, see "Patched versions". An advisory is also published for ibexa/solr, please see that repository. Commit: https://github.com/ezsystems/ezplatform-solr-search-engine/commit/1005e02cc32ff15a705857fa56171528a83b9c3e Workarounds None. References https://developers.ibexa.co/security-advisories/ibexa-sa-2023-005-vulnerabilities-in-solr-search-and-file-downloads

    Recommended action: Upgrade to 3.3.15, 2.0.2 or 1.7.12 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →