Json response for search reveals Solr credentials
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezplatform-solr-search-engine 3.3.15, 2.0.2, 1.7.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezplatform-solr-search-engine
- Affected
- >= 3.3.0, < 3.3.15>= 2.0.0, < 2.0.2>= 1.7.0, < 1.7.12
- Fixed in
- 3.3.15, 1.7.12, 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7crc-r3wg-cfgf lists affected ranges: Packagist ezsystems/ezplatform-solr-search-engine >=3.3.0 =2.0.0 =1.7.0 <1.7.12
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact An error in Ibexa's Solr search engine results in potential exposure of Solr credentials. This is a critical vulnerability and all supported versions of the engine are affected. Those not using the Solr search engine are not affected. Patches The issue is fixed in all supported versions of ezsystems/ezplatform-solr-search-engine, see "Patched versions". An advisory is also published for ibexa/solr, please see that repository. Commit: https://github.com/ezsystems/ezplatform-solr-search-engine/commit/1005e02cc32ff15a705857fa56171528a83b9c3e Workarounds None. References https://developers.ibexa.co/security-advisories/ibexa-sa-2023-005-vulnerabilities-in-solr-search-and-file-downloads
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7crc-r3wg-cfgf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-7crc-r3wg-cfgf Advisory: Json response for search reveals Solr credentials IDs: GHSA-7crc-r3wg-cfgf Record: https://patchnext.com/advisories/ghsa-7crc-r3wg-cfgf (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezplatform-solr-search-engine 3.3.15, 2.0.2, 1.7.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezplatform-solr-search-engine: affected >= 3.3.0, < 3.3.15; >= 2.0.0, < 2.0.2; >= 1.7.0, < 1.7.12; fixed in 3.3.15, 1.7.12, 2.0.2 ## Suggested inspection (read-only) - Packagist ezsystems/ezplatform-solr-search-engine: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezplatform-solr-search-engine. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7crc-r3wg-cfgf (GitHub-reviewed advisory GHSA-7crc-r3wg-cfgf lists affected ranges: Packagist ezsystems/ezplatform-solr-search-engine >=3.3.0 =2.0.0 =1.7.0 <1.7.12) Commands are suggestions: review each one before running it.
Loading voting…