High, CVSS 8.1PackagistPublished
Drupal OAuth2 Server Missing Authorization vulnerability
CVE-2025-31691 · GHSA-4f8q-mwgc-3mwc
- Affected
- Packagist drupal/oauth2_server < 2.1.0
- Fixed in
- 2.1.0· Vendor fix available
- Issue
- Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing. This issue affects OAuth2 Server: from 0.0.0 before 2.1.0.
Recommended action: Upgrade to 2.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.