Drupal OAuth2 Server Missing Authorization vulnerability
CVE-2025-31691GHSA-4f8q-mwgc-3mwc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/oauth2_server 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/oauth2_server
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4f8q-mwgc-3mwc lists affected ranges: Packagist drupal/oauth2_server >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-31691: 0.43% estimated exploitation activity in the next 30 days; percentile 37.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Missing Authorization vulnerability in Drupal OAuth2 Server allows Forceful Browsing. This issue affects OAuth2 Server: from 0.0.0 before 2.1.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4f8q-mwgc-3mwc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31691 Advisory: Drupal OAuth2 Server Missing Authorization vulnerability IDs: CVE-2025-31691, GHSA-4f8q-mwgc-3mwc Record: https://patchnext.com/advisories/cve-2025-31691 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/oauth2_server 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/oauth2_server: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Packagist drupal/oauth2_server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/oauth2_server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4f8q-mwgc-3mwc (GitHub-reviewed advisory GHSA-4f8q-mwgc-3mwc lists affected ranges: Packagist drupal/oauth2_server >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…