Low, CVSS 1.3PackagistPublished
Drupal Link field display mode formatter Cross-Site Scripting (XSS) vulnerability
CVE-2025-31695 · GHSA-p2wg-8h29-874v
- Affected
- Packagist drupal/link_field_display_mode_formatter < 1.6.0
- Fixed in
- 1.6.0· Vendor fix available
- Issue
- Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Link field display mode formatter allows Cross-Site Scripting (XSS). This issue affects Link field display mode formatter: from 0.0.0 before 1.6.0.
Recommended action: Upgrade to 1.6.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.