Drupal Link field display mode formatter Cross-Site Scripting (XSS) vulnerability
CVE-2025-31695GHSA-p2wg-8h29-874v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/link_field_display_mode_formatter 1.6.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/link_field_display_mode_formatter
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p2wg-8h29-874v lists affected ranges: Packagist drupal/link_field_display_mode_formatter >=0 <1.6.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2025-31695: 0.26% estimated exploitation activity in the next 30 days; percentile 18.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Link field display mode formatter allows Cross-Site Scripting (XSS). This issue affects Link field display mode formatter: from 0.0.0 before 1.6.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p2wg-8h29-874v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-31695 Advisory: Drupal Link field display mode formatter Cross-Site Scripting (XSS) vulnerability IDs: CVE-2025-31695, GHSA-p2wg-8h29-874v Record: https://patchnext.com/advisories/cve-2025-31695 (revision 1, source checked 26 Oct 2026, 14:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/link_field_display_mode_formatter 1.6.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/link_field_display_mode_formatter: affected < 1.6.0; fixed in 1.6.0 ## Suggested inspection (read-only) - Packagist drupal/link_field_display_mode_formatter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/link_field_display_mode_formatter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p2wg-8h29-874v (GitHub-reviewed advisory GHSA-p2wg-8h29-874v lists affected ranges: Packagist drupal/link_field_display_mode_formatter >=0 <1.6.0) Commands are suggestions: review each one before running it.
Loading voting…