Medium, CVSS 5.1PackagistPublished
Drupal General Data Protection Regulation Cross-Site Request Forgery (CSRF) vulnerability
CVE-2025-31689 · GHSA-jv6r-mj9p-9xff
- Affected
- Packagist drupal/gdpr < 3.0.1; >= 3.1.0, < 3.1.2
- Fixed in
- 3.0.13.1.2· Vendor fix available
- Issue
- Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery. This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.
Recommended action: Upgrade to 3.1.2 or 3.0.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.