Skip to content

← Actionable
Medium, CVSS 5.1

Drupal General Data Protection Regulation Cross-Site Request Forgery (CSRF) vulnerability

CVE-2025-31689GHSA-jv6r-mj9p-9xff

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/gdpr 3.1.2, 3.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/gdpr

    Affected
    < 3.0.1>= 3.1.0, < 3.1.2
    Fixed in
    3.0.1, 3.1.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-31689: 0.21% estimated exploitation activity in the next 30 days; percentile 11.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Cross-Site Request Forgery (CSRF) vulnerability in Drupal General Data Protection Regulation allows Cross Site Request Forgery. This issue affects General Data Protection Regulation: from 0.0.0 before 3.0.1, from 3.1.0 before 3.1.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jv6r-mj9p-9xff

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31689

Advisory: Drupal General Data Protection Regulation Cross-Site Request Forgery (CSRF) vulnerability
IDs: CVE-2025-31689, GHSA-jv6r-mj9p-9xff
Record: https://patchnext.com/advisories/cve-2025-31689 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/gdpr 3.1.2, 3.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/gdpr: affected < 3.0.1; >= 3.1.0, < 3.1.2; fixed in 3.0.1, 3.1.2

## Suggested inspection (read-only)
- Packagist drupal/gdpr: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/gdpr.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jv6r-mj9p-9xff (GitHub-reviewed advisory GHSA-jv6r-mj9p-9xff lists affected ranges: Packagist drupal/gdpr >=0 =3.1.0 <3.1.2)

Commands are suggestions: review each one before running it.

Loading voting…