Skip to content

← Public intelligence

Packagist package

drupal/ai

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

4 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.9PackagistPublished

    Drupal AI Vulnerable to OS Command Injection via Optional Automator Types

    CVE-2025-31692 · GHSA-pwjq-fx3v-8f9r

    Affected
    • Packagist drupal/ai < 1.0.5
    Fixed in
    1.0.5· Vendor fix available
    Issue
    Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.

    Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.5PackagistPublished

    Drupal AI Vulnerable to OS Command Injection

    CVE-2025-31693 · GHSA-vx9m-rfxq-gr74

    Affected
    • Packagist drupal/ai < 1.0.5
    Fixed in
    1.0.5· Vendor fix available
    Issue
    Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Drupal AI (Artificial Intelligence) allows OS Command Injection. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.5.

    Recommended action: Upgrade to 1.0.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 6.3PackagistPublished

    Drupal AI Cross-Site Request Forgery (CSRF) vulnerability

    CVE-2025-31677 · GHSA-9w85-x5hg-fr66

    Affected
    • Packagist drupal/ai >= 1.0.0, < 1.0.2
    Fixed in
    1.0.2· Vendor fix available
    Issue
    Cross-Site Request Forgery (CSRF) vulnerability in Drupal AI (Artificial Intelligence) allows Cross Site Request Forgery. This issue affects AI (Artificial Intelligence): from 1.0.0 before 1.0.2.

    Recommended action: Upgrade to 1.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Medium, CVSS 6.7PackagistPublished

    Drupal AI Missing Authorization vulnerability

    CVE-2025-31678 · GHSA-c8q6-wp7v-46r9

    Affected
    • Packagist drupal/ai < 1.0.3
    Fixed in
    1.0.3· Vendor fix available
    Issue
    Missing Authorization vulnerability in Drupal AI (Artificial Intelligence) allows Forceful Browsing. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.3.

    Recommended action: Upgrade to 1.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →