Skip to content

← Actionable
Medium, CVSS 6.7

Drupal AI Missing Authorization vulnerability

CVE-2025-31678GHSA-c8q6-wp7v-46r9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/ai 1.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/ai

    Affected
    < 1.0.3
    Fixed in
    1.0.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2025-31678: 0.38% estimated exploitation activity in the next 30 days; percentile 32.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Missing Authorization vulnerability in Drupal AI (Artificial Intelligence) allows Forceful Browsing. This issue affects AI (Artificial Intelligence): from 0.0.0 before 1.0.3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c8q6-wp7v-46r9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-31678

Advisory: Drupal AI Missing Authorization vulnerability
IDs: CVE-2025-31678, GHSA-c8q6-wp7v-46r9
Record: https://patchnext.com/advisories/cve-2025-31678 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/ai 1.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/ai: affected < 1.0.3; fixed in 1.0.3

## Suggested inspection (read-only)
- Packagist drupal/ai: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/ai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c8q6-wp7v-46r9 (GitHub-reviewed advisory GHSA-c8q6-wp7v-46r9 lists affected ranges: Packagist drupal/ai >=0 <1.0.3)

Commands are suggestions: review each one before running it.

Loading voting…