Skip to content

← Public intelligence

Packagist package

doctrine/dbal

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PackagistPublished

    Doctrine DBAL SQL injection possibility

    GHSA-76w8-mqx4-wjrf

    Affected
    • Packagist doctrine/dbal >= 2.0.0, < 2.0.8; >= 2.1.0, < 2.1.2
    Fixed in
    2.1.22.0.8· Vendor fix available
    Issue
    The identifier quoting in Doctrine DBAL has a potential security problem when user-input is passed into this function, making the security aspect of this functionality obsolete. If you make use of AbstractPlatform::quoteIdentifier() or Doctrine::quoteIdentifier() please upgrade immediately. The ORM itself does not use identifier quoting in combination with user-input, however we still urge everyone to update to the latest version of DBAL.

    Recommended action: Upgrade to 2.1.2 or 2.0.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Critical, CVSS 9.8PackagistPublished

    DBAL 3 SQL Injection Security Vulnerability

    CVE-2021-43608 · GHSA-r7cj-8hjg-x622

    Affected
    • Packagist doctrine/dbal >= 3.0.0, < 3.1.4
    Fixed in
    3.1.4· Vendor fix available
    Issue
    We have released a new version Doctrine DBAL 3.1.4 that fixes a critical SQL injection vulnerability in the LIMIT clause generation API provided by the Platform abstraction. We advise everyone using Doctrine DBAL 3.0.0 up to 3.1.3 to upgrade to 3.1.4 immediately. The vulnerability can happen when unsanitized input is passed to many APIs in Doctrine DBAL and ORM that ultimately end up calling AbstractPlatform::modifyLimitQuery. As a workaround you can cast all limit and offset parameters to integers before passing them to Doctrine APIs. This vulnerability has been assigned CVE-2021-43608.

    Recommended action: Upgrade to 3.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →