Doctrine DBAL SQL injection possibility
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (doctrine/dbal 2.1.2, 2.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist doctrine/dbal
- Affected
- >= 2.0.0, < 2.0.8>= 2.1.0, < 2.1.2
- Fixed in
- 2.1.2, 2.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-76w8-mqx4-wjrf lists affected ranges: Packagist doctrine/dbal >=2.0.0 =2.1.0 <2.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The identifier quoting in Doctrine DBAL has a potential security problem when user-input is passed into this function, making the security aspect of this functionality obsolete. If you make use of AbstractPlatform::quoteIdentifier() or Doctrine::quoteIdentifier() please upgrade immediately. The ORM itself does not use identifier quoting in combination with user-input, however we still urge everyone to update to the latest version of DBAL.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-76w8-mqx4-wjrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-76w8-mqx4-wjrf Advisory: Doctrine DBAL SQL injection possibility IDs: GHSA-76w8-mqx4-wjrf Record: https://patchnext.com/advisories/ghsa-76w8-mqx4-wjrf (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: doctrine/dbal 2.1.2, 2.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist doctrine/dbal: affected >= 2.0.0, < 2.0.8; >= 2.1.0, < 2.1.2; fixed in 2.1.2, 2.0.8 ## Suggested inspection (read-only) - Packagist doctrine/dbal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on doctrine/dbal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-76w8-mqx4-wjrf (GitHub-reviewed advisory GHSA-76w8-mqx4-wjrf lists affected ranges: Packagist doctrine/dbal >=2.0.0 =2.1.0 <2.1.2) Commands are suggestions: review each one before running it.
Loading voting…