UnratedPackagistPublished
CiviCRM SQL injection vulnerability via Quick Search API
CVE-2013-4662 · GHSA-4465-r2hg-v4rj
- Affected
- Packagist civicrm/civicrm-core >= 4.2.0, < 4.2.9; >= 4.3.0, < 4.3.3
- Fixed in
- 4.2.94.3.3· Vendor fix available
- Issue
- The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
Recommended action: Upgrade to 4.3.3 or 4.2.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.