CiviCRM SQL injection vulnerability via Quick Search API
CVE-2013-4662GHSA-4465-r2hg-v4rj
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (civicrm/civicrm-core 4.3.3, 4.2.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist civicrm/civicrm-core
- Affected
- >= 4.2.0, < 4.2.9>= 4.3.0, < 4.3.3
- Fixed in
- 4.2.9, 4.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4465-r2hg-v4rj lists affected ranges: Packagist civicrm/civicrm-core >=4.2.0 =4.3.0 <4.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-4662: 1.01% estimated exploitation activity in the next 30 days; percentile 63.33 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Quick Search API in CiviCRM 4.2.0 through 4.2.9 and 4.3.0 through 4.3.3 allows remote authenticated users to bypass the validation layer and conduct SQL injection attacks via a direct request to the "second layer" of the API, related to contact.getquick.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4465-r2hg-v4rj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-4662 Advisory: CiviCRM SQL injection vulnerability via Quick Search API IDs: CVE-2013-4662, GHSA-4465-r2hg-v4rj Record: https://patchnext.com/advisories/cve-2013-4662 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: civicrm/civicrm-core 4.3.3, 4.2.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist civicrm/civicrm-core: affected >= 4.2.0, < 4.2.9; >= 4.3.0, < 4.3.3; fixed in 4.2.9, 4.3.3 ## Suggested inspection (read-only) - Packagist civicrm/civicrm-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on civicrm/civicrm-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4465-r2hg-v4rj (GitHub-reviewed advisory GHSA-4465-r2hg-v4rj lists affected ranges: Packagist civicrm/civicrm-core >=4.2.0 =4.3.0 <4.3.3) Commands are suggestions: review each one before running it.
Loading voting…