Skip to content

← Public intelligence

Packagist package

cardgate/woocommerce

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.1PackagistPublished

    CardGate Payments plugin for WooCommerce does not validate request origin

    CVE-2020-8819 · GHSA-5pq5-9phv-q5j3

    Affected
    • Packagist cardgate/woocommerce <= 3.1.15
    Fixed in
    3.1.16· Vendor fix available
    Issue
    An issue was discovered in the CardGate Payments plugin through 3.1.15 for WooCommerce. Lack of origin authentication in the IPN callback processing function in cardgate/cardgate.php allows an attacker to remotely replace critical plugin settings (merchant ID, secret key, etc.) and therefore bypass the payment process (e.g., spoof an order status by manually sending an IPN callback request with a valid signature but without real payment) and/or receive all of the subsequent payments.

    Recommended action: Upgrade to 3.1.16 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →