Skip to content

← Actionable
High, CVSS 8.1

CardGate Payments plugin for WooCommerce does not validate request origin

CVE-2020-8819GHSA-5pq5-9phv-q5j3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cardgate/woocommerce 3.1.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2020-8819: 4.88% estimated exploitation activity in the next 30 days; percentile 92.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the CardGate Payments plugin through 3.1.15 for WooCommerce. Lack of origin authentication in the IPN callback processing function in cardgate/cardgate.php allows an attacker to remotely replace critical plugin settings (merchant ID, secret key, etc.) and therefore bypass the payment process (e.g., spoof an order status by manually sending an IPN callback request with a valid signature but without real payment) and/or receive all of the subsequent payments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5pq5-9phv-q5j3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-8819

Advisory: CardGate Payments plugin for WooCommerce does not validate request origin
IDs: CVE-2020-8819, GHSA-5pq5-9phv-q5j3
Record: https://patchnext.com/advisories/cve-2020-8819 (revision 1, source checked 26 Oct 2026, 14:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cardgate/woocommerce 3.1.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cardgate/woocommerce: affected <= 3.1.15; fixed in 3.1.16

## Suggested inspection (read-only)
- Packagist cardgate/woocommerce: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cardgate/woocommerce.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5pq5-9phv-q5j3 (GitHub-reviewed advisory GHSA-5pq5-9phv-q5j3 lists affected ranges: Packagist cardgate/woocommerce >=0 <=3.1.15)

Commands are suggestions: review each one before running it.

Loading voting…