Medium, CVSS 5.4PackagistPublished
brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
CVE-2022-33154 · GHSA-374w-gwqr-fmxg
- Affected
- Packagist brotkrueml/schema >= 2.0.0, < 2.5.1; < 1.13.1
- Fixed in
- 2.5.11.13.1· Vendor fix available
- Issue
- The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Recommended action: Upgrade to 2.5.1 or 1.13.1 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.