Skip to content

← Actionable
Medium, CVSS 5.4

brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS

CVE-2022-33154GHSA-374w-gwqr-fmxg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (brotkrueml/schema 2.5.1, 1.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2022-33154: 0.52% estimated exploitation activity in the next 30 days; percentile 44.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-374w-gwqr-fmxg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2022-33154

Advisory: brotkrueml/schema fails to properly encode user input for output in HTML context, leading to XSS
IDs: CVE-2022-33154, GHSA-374w-gwqr-fmxg
Record: https://patchnext.com/advisories/cve-2022-33154 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: brotkrueml/schema 2.5.1, 1.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist brotkrueml/schema: affected >= 2.0.0, < 2.5.1; < 1.13.1; fixed in 2.5.1, 1.13.1

## Suggested inspection (read-only)
- Packagist brotkrueml/schema: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on brotkrueml/schema.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-374w-gwqr-fmxg (GitHub-reviewed advisory GHSA-374w-gwqr-fmxg lists affected ranges: Packagist brotkrueml/schema >=2.0.0 =0 <1.13.1)

Commands are suggestions: review each one before running it.

Loading voting…