Skip to content

← Public intelligence

Packagist package

brotkrueml/codehighlight

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.0PackagistPublished

    Denial of Service in extension "Code Highlight" (codehighlight)

    GHSA-4cv2-xc5f-px8h

    Affected
    • Packagist brotkrueml/codehighlight < 2.5.0
    Fixed in
    2.5.0· Vendor fix available
    Issue
    The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).

    Recommended action: Upgrade to 2.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.7PackagistPublished

    Denial of Service in extension "Code Highlight" (codehighlight)

    GHSA-65xh-hh78-6454

    Affected
    • Packagist brotkrueml/codehighlight < 2.7.0
    Fixed in
    2.7.0· Vendor fix available
    Issue
    The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).

    Recommended action: Upgrade to 2.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →