Denial of Service in extension "Code Highlight" (codehighlight)
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (brotkrueml/codehighlight 2.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist brotkrueml/codehighlight
- Affected
- < 2.5.0
- Fixed in
- 2.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4cv2-xc5f-px8h lists affected ranges: Packagist brotkrueml/codehighlight >=0 <2.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:N/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4cv2-xc5f-px8h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-4cv2-xc5f-px8h Advisory: Denial of Service in extension "Code Highlight" (codehighlight) IDs: GHSA-4cv2-xc5f-px8h Record: https://patchnext.com/advisories/ghsa-4cv2-xc5f-px8h (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: brotkrueml/codehighlight 2.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist brotkrueml/codehighlight: affected < 2.5.0; fixed in 2.5.0 ## Suggested inspection (read-only) - Packagist brotkrueml/codehighlight: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on brotkrueml/codehighlight. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4cv2-xc5f-px8h (GitHub-reviewed advisory GHSA-4cv2-xc5f-px8h lists affected ranges: Packagist brotkrueml/codehighlight >=0 <2.5.0) Commands are suggestions: review each one before running it.
Loading voting…