Skip to content

← Public intelligence

Packagist package

bottelet/flarepoint

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4PackagistPublished

    Cross-site Scripting in DayByDay CRM

    CVE-2022-22109 · GHSA-jr37-66pj-36v7

    Affected
    • Packagist bottelet/flarepoint < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    In Daybyday CRM, version 2.2.0 is vulnerable to Stored Cross-Site Scripting (XSS) vulnerability that allows low privileged application users to store malicious scripts in the title field of new tasks. These scripts are executed in a victim’s browser when they open the “/tasks” page to view all the tasks.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 4.3PackagistPublished

    Missing Authorization in DayByDay CRM

    CVE-2022-22107 · GHSA-44gv-fgcj-w546

    Affected
    • Packagist bottelet/flarepoint >= 2.0.0, < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    In Daybyday CRM, versions 2.0.0 through 2.2.0 are vulnerable to Missing Authorization. An attacker that has the lowest privileges account (employee type user), can view the appointments of all users in the system including administrators. However, this type of user is not authorized to view the calendar at all.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Medium, CVSS 4.3PackagistPublished

    Missing Authorization in DayByDay CRM

    CVE-2022-22108 · GHSA-frxp-xxx8-hrg6

    Affected
    • Packagist bottelet/flarepoint >= 2.0.0, < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    In Daybyday CRM, versions 2.0.0 through 2.2.0 are vulnerable to Missing Authorization. An attacker that has the lowest privileges account (employee type user), can view the absences of all users in the system including administrators. This type of user is not authorized to view this kind of information.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. High, CVSS 7.5PackagistPublished

    Weak Password Requirements in Daybyday CRM

    CVE-2022-22110 · GHSA-96v6-hrwg-p378

    Affected
    • Packagist bottelet/flarepoint >= 1.1, < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    In Daybyday CRM, versions 1.1 through 2.2.0 enforce weak password requirements in the user update functionality. A user with privileges to update his password could change it to a weak password, such as those with a length of a single character. This may allow an attacker to brute-force users’ passwords with minimal to no computational effort.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8PackagistPublished

    Missing Authorization in DayByDay CRM

    CVE-2022-22111 · GHSA-w6rp-4vj7-v2m8

    Affected
    • Packagist bottelet/flarepoint < 2.2.1
    Fixed in
    2.2.1· Vendor fix available
    Issue
    In DayByDay CRM, version 2.2.0 is vulnerable to missing authorization. Any application user in the application who has update user permission enabled is able to change the password of other users, including the administrator’s. This allows the attacker to gain access to the highest privileged user in the application.

    Recommended action: Upgrade to 2.2.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →