Cross-site Scripting in DayByDay CRM
CVE-2022-22109GHSA-jr37-66pj-36v7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bottelet/flarepoint 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist bottelet/flarepoint
- Affected
- < 2.2.1
- Fixed in
- 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jr37-66pj-36v7 lists affected ranges: Packagist bottelet/flarepoint >=0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-22109: 0.55% estimated exploitation activity in the next 30 days; percentile 46.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In Daybyday CRM, version 2.2.0 is vulnerable to Stored Cross-Site Scripting (XSS) vulnerability that allows low privileged application users to store malicious scripts in the title field of new tasks. These scripts are executed in a victim’s browser when they open the “/tasks” page to view all the tasks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jr37-66pj-36v7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-22109 Advisory: Cross-site Scripting in DayByDay CRM IDs: CVE-2022-22109, GHSA-jr37-66pj-36v7 Record: https://patchnext.com/advisories/cve-2022-22109 (revision 1, source checked 26 Oct 2026, 14:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bottelet/flarepoint 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist bottelet/flarepoint: affected < 2.2.1; fixed in 2.2.1 ## Suggested inspection (read-only) - Packagist bottelet/flarepoint: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bottelet/flarepoint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jr37-66pj-36v7 (GitHub-reviewed advisory GHSA-jr37-66pj-36v7 lists affected ranges: Packagist bottelet/flarepoint >=0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…