Medium, CVSS 5.4PackagistPublished
Cross-Site Scripting in Bootstrap Package
CVE-2021-21365 · GHSA-p48w-vf3c-rqjx
- Affected
- Packagist bk2k/bootstrap-package >= 7.1.0, < 7.1.2; >= 8.0.0, < 8.0.8; >= 9.0.0, < 9.0.4; >= 9.1.0, < 9.1.3; >= 10.0.0, < 10.0.10; >= 11.0.0, < 11.0.3
- Fixed in
- 9.1.38.0.811.0.310.0.107.1.29.0.4· Vendor fix available
- Issue
- Problem It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. The following templates are affected by the vulnerability: Resources/Private/Partials/ContentElements/Carousel/Item/CallToAction.html Resources/Private/Partials/ContentElements/Carousel/Item/Header.html Resources/Private/Partials/ContentElements/Carousel/Item/Text.html Resources/Private/Partials/ContentElements/Carousel/Item/TextAndImage.html Resources/Private/Partials/ContentElements/Header/SubHeader.html Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix as shown in this Git commit. Solution Update to version 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at…
Recommended action: Upgrade to 11.0.3, 10.0.10, 9.1.3 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.