Skip to content

← Actionable
Medium, CVSS 5.4

Cross-Site Scripting in Bootstrap Package

CVE-2021-21365GHSA-p48w-vf3c-rqjx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bk2k/bootstrap-package 11.0.3, 10.0.10, 9.1.3, 9.0.4, 8.0.8, 7.1.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist bk2k/bootstrap-package

    Affected
    >= 7.1.0, < 7.1.2>= 8.0.0, < 8.0.8>= 9.0.0, < 9.0.4>= 9.1.0, < 9.1.3>= 10.0.0, < 10.0.10>= 11.0.0, < 11.0.3
    Fixed in
    9.1.3, 8.0.8, 11.0.3, 10.0.10, 7.1.2, 9.0.4

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-p48w-vf3c-rqjx lists affected ranges: Packagist bk2k/bootstrap-package >=7.1.0 =8.0.0 =9.0.0 =9.1.0 =10.0.0 =11.0.0 <11.0.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2021-21365: 0.94% estimated exploitation activity in the next 30 days; percentile 61.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Problem It has been discovered that rendering content in the website frontend is vulnerable to cross-site scripting. A valid backend user account is needed to exploit this vulnerability. The following templates are affected by the vulnerability: Resources/Private/Partials/ContentElements/Carousel/Item/CallToAction.html Resources/Private/Partials/ContentElements/Carousel/Item/Header.html Resources/Private/Partials/ContentElements/Carousel/Item/Text.html Resources/Private/Partials/ContentElements/Carousel/Item/TextAndImage.html Resources/Private/Partials/ContentElements/Header/SubHeader.html Users of the extension, who have overwritten the affected templates with custom code must manually apply the security fix as shown in this Git commit. Solution Update to version 7.1.2, 8.0.8, 9.0.4, 9.1.3, 10.0.10 or 11.0.3 of the Bootstrap Package that fix the problem described. Updated version are available from the TYPO3 extension manager, Packagist and at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p48w-vf3c-rqjx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-21365

Advisory: Cross-Site Scripting in Bootstrap Package
IDs: CVE-2021-21365, GHSA-p48w-vf3c-rqjx
Record: https://patchnext.com/advisories/cve-2021-21365 (revision 1, source checked 26 Oct 2026, 14:01 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bk2k/bootstrap-package 11.0.3, 10.0.10, 9.1.3, 9.0.4, 8.0.8, 7.1.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist bk2k/bootstrap-package: affected >= 7.1.0, < 7.1.2; >= 8.0.0, < 8.0.8; >= 9.0.0, < 9.0.4; >= 9.1.0, < 9.1.3; >= 10.0.0, < 10.0.10; >= 11.0.0, < 11.0.3; fixed in 9.1.3, 8.0.8, 11.0.3, 10.0.10, 7.1.2, 9.0.4

## Suggested inspection (read-only)
- Packagist bk2k/bootstrap-package: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bk2k/bootstrap-package.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p48w-vf3c-rqjx (GitHub-reviewed advisory GHSA-p48w-vf3c-rqjx lists affected ranges: Packagist bk2k/bootstrap-package >=7.1.0 =8.0.0 =9.0.0 =9.1.0 =10.0.0 =11.0.0 <11.0.3)

Commands are suggestions: review each one before running it.

Loading voting…