Skip to content

← Public intelligence

Packagist package

billz/raspap-webgui

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.7PackagistPublished

    RaspAP raspap-webgui contains an OS Command Injection vulnerability

    CVE-2026-24788 · GHSA-4wwf-f7w3-94f5

    Affected
    • Packagist billz/raspap-webgui < 3.3.6
    Fixed in
    3.3.6· Vendor fix available
    Issue
    RaspAP raspap-webgui versions prior to 3.3.6 contain an OS Command Injection vulnerability. If exploited, an arbitrary OS command may be executed by a user who can log in to the product.

    Recommended action: Upgrade to 3.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 7.7PackagistPublished

    raspap-webgui has a Directory Traversal vulnerability

    CVE-2025-44163 · GHSA-277f-37gw-9gmq

    Affected
    • Packagist billz/raspap-webgui < 3.3.6
    Fixed in
    3.3.6· Vendor fix available
    Issue
    RaspAP raspap-webgui 3.3.1 is vulnerable to Directory Traversal in ajax/networking/getwgkey.php. An authenticated attacker can send a crafted POST request with a path traversal payload in the entity parameter to overwrite arbitrary files writable by the web server via abuse of the tee command used in shell execution.

    Recommended action: Upgrade to 3.3.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. High, CVSS 7.7PackagistPublished

    raspap-webgui vulnerable to denial of service

    CVE-2024-28754 · GHSA-vc9f-mgxr-h32r

    Affected
    • Packagist billz/raspap-webgui < 3.1.0
    Fixed in
    3.1.0· Vendor fix available
    Issue
    RaspAP (aka raspap-webgui) through 3.0.9 allows remote attackers to cause a persistent denial of service (bricking) via a crafted request.

    Recommended action: Upgrade to 3.1.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.8PackagistPublished

    RaspAP Command Injection vulnerability

    CVE-2022-39986 · GHSA-7c28-wg7r-pg6f

    Affected
    • Packagist billz/raspap-webgui >= 2.8.0, < 2.8.8
    Fixed in
    2.8.8· Vendor fix available
    Issue
    A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfgid parameter in /ajax/openvpn/activateovpncfg.php and /ajax/openvpn/delovpncfg.php.

    Recommended action: Upgrade to 2.8.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. High, CVSS 8.8PackagistPublished

    RaspAP Command Injection vulnerability

    CVE-2022-39987 · GHSA-7r88-wjhj-jr8m

    Affected
    • Packagist billz/raspap-webgui >= 2.8.0, < 2.9.5
    Fixed in
    2.9.5· Vendor fix available
    Issue
    A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated attacker to execute arbitrary OS commands as root via the entity POST parameters in /ajax/networking/getwgkey.php.

    Recommended action: Upgrade to 2.9.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  6. High, CVSS 8.8PackagistPublished

    RaspAP raspap-webgui Command Injection vulnerability

    CVE-2023-30260 · GHSA-hhqm-f4m4-pq39

    Affected
    • Packagist billz/raspap-webgui < 2.8.9
    Fixed in
    2.8.9· Vendor fix available
    Issue
    Command injection vulnerability in RaspAP raspap-webgui 2.8.8 and earlier allows remote attackers to run arbitrary commands via crafted POST request to hostapd settings form.

    Recommended action: Upgrade to 2.8.9 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →