Skip to content

← Actionable
High, CVSS 8.7

RaspAP raspap-webgui contains an OS Command Injection vulnerability

CVE-2026-24788GHSA-4wwf-f7w3-94f5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (billz/raspap-webgui 3.3.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-24788: 1.35% estimated exploitation activity in the next 30 days; percentile 71.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

RaspAP raspap-webgui versions prior to 3.3.6 contain an OS Command Injection vulnerability. If exploited, an arbitrary OS command may be executed by a user who can log in to the product.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4wwf-f7w3-94f5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-24788

Advisory: RaspAP raspap-webgui contains an OS Command Injection vulnerability
IDs: CVE-2026-24788, GHSA-4wwf-f7w3-94f5
Record: https://patchnext.com/advisories/cve-2026-24788 (revision 1, source checked 26 Oct 2026, 14:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: billz/raspap-webgui 3.3.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist billz/raspap-webgui: affected < 3.3.6; fixed in 3.3.6

## Suggested inspection (read-only)
- Packagist billz/raspap-webgui: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on billz/raspap-webgui.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4wwf-f7w3-94f5 (GitHub-reviewed advisory GHSA-4wwf-f7w3-94f5 lists affected ranges: Packagist billz/raspap-webgui >=0 <3.3.6)

Commands are suggestions: review each one before running it.

Loading voting…