High, CVSS 8.5PackagistPublished
FileManager Deserialization of Untrusted Data vulnerability
CVE-2024-52306 · GHSA-8237-957h-h2c2
- Affected
- Packagist backpack/filemanager >= 3.0.0, < 3.0.9; < 2.0.2
- Fixed in
- 3.0.92.0.2· Vendor fix available
- Issue
- Impact Deserialization of untrusted data from the mimes parameter could lead to remote code execution. Patches Fixed in 3.0.9 Workarounds Not needed, a composer update will solve it in a non-breaking way. References Reported responsibly Vladislav Gladkiy at Positive Technologies.
Recommended action: Upgrade to 3.0.9 or 2.0.2 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.