Skip to content

← Actionable
High, CVSS 8.5

FileManager Deserialization of Untrusted Data vulnerability

CVE-2024-52306GHSA-8237-957h-h2c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (backpack/filemanager 3.0.9, 2.0.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.5 · CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2024-52306: 0.63% estimated exploitation activity in the next 30 days; percentile 50.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Deserialization of untrusted data from the mimes parameter could lead to remote code execution. Patches Fixed in 3.0.9 Workarounds Not needed, a composer update will solve it in a non-breaking way. References Reported responsibly Vladislav Gladkiy at Positive Technologies.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8237-957h-h2c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2024-52306

Advisory: FileManager Deserialization of Untrusted Data vulnerability
IDs: CVE-2024-52306, GHSA-8237-957h-h2c2
Record: https://patchnext.com/advisories/cve-2024-52306 (revision 1, source checked 26 Oct 2026, 14:28 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: backpack/filemanager 3.0.9, 2.0.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist backpack/filemanager: affected >= 3.0.0, < 3.0.9; < 2.0.2; fixed in 3.0.9, 2.0.2

## Suggested inspection (read-only)
- Packagist backpack/filemanager: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on backpack/filemanager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8237-957h-h2c2 (GitHub-reviewed advisory GHSA-8237-957h-h2c2 lists affected ranges: Packagist backpack/filemanager >=3.0.0 =0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…