Skip to content

← Public intelligence

Packagist package

auth0/login

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2PackagistPublished

    Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption

    GHSA-fmg6-246m-9g2v

    Affected
    • Packagist auth0/login >= 7.0.0, <= 7.20.0
    Fixed in
    7.21.0· Vendor fix available
    Issue
    Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. Am I Affected? You are affected if you meet the following preconditions: - Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0 - Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. Resolution Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.

    Recommended action: Upgrade to 7.21.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. Medium, CVSS 6.8PackagistPublished

    Auth0 Laravel SDK has Improper Audience Validation via Auth0-PHP SDK dependency

    GHSA-7hh9-gp72-wh7h

    Affected
    • Packagist auth0/login >= 7.0.0, < 7.20.0
    Fixed in
    7.20.0· Vendor fix available
    Issue
    In applications built with the Auth0-PHP SDK, the audience validation in access tokens is performed improperly. Without proper validation, affected applications may accept ID tokens as Access tokens. Affected product and versions Users are affected if they meet the following preconditions: - Applications using the Auth0 laravel-auth0 SDK with versions between 7.0.0 and 7.19.0, - Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 8.0.0 and 8.17.0. Resolution Upgrade Auth0/laravel-auth0 to version 7.20.0 or greater. Acknowledgement Okta would like to thank Jafar Sadiq (iaf4r) for their discovery and responsible disclosure.

    Recommended action: Upgrade to 7.20.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  3. Low, CVSS 3.3PackagistPublished

    laravel-auth0 SDK Does Not Properly Handle File Types in Bulk User Import

    GHSA-hjfh-5jmm-xr24

    Affected
    • Packagist auth0/login >= 4.0.0, <= 7.18.0
    Fixed in
    7.19.0· Vendor fix available
    Issue
    In applications built with the Auth0-PHP SDK, the Bulk User Import endpoint does not validate the file path wrapper or value. Without proper validation, affected applications may accept arbitrary file paths or URLs. Am I affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 laravel-auth0 SDK with version between 4.0.0 and 7.18.0, 2. Auth0 laravel-auth0 SDK uses the Auth0-PHP SDK with versions between 3.3.0 and 8.16.0. Fix Upgrade Auth0 laravel-auth0 SDK to version 7.19.0 or greater. Acknowledgement Okta would like to thank Mohamed Amine Saidani (pwni) for discovering this vulnerability.

    Recommended action: Upgrade to 7.19.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  4. Critical, CVSS 9.3PackagistPublished

    laravel-auth0 SDK Deserialization of Untrusted Data vulnerability

    GHSA-c42h-56wx-h85q

    Affected
    • Packagist auth0/login >= 7.0.0-BETA1, <= 7.2.1
    Fixed in
    7.2.2· Vendor fix available
    Issue
    The laravel-auth0 SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. Am I Affected? You are affected by this vulnerability if you meet the following preconditions: 1. Applications using laravel-auth0 SDK, versions between 7.0.0-BETA1 to 7.2.1. 2. Laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. Fix Upgrade Auth0/laravel-auth0 to the latest version (v7.17.0). Acknowledgement Okta would like to thank Andreas Forsblom for discovering this vulnerability.

    Recommended action: Upgrade to 7.2.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  5. Critical, CVSS 9.1PackagistPublished

    laravel-auth0 SDK Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

    GHSA-9fwj-9mjf-rhj3

    Affected
    • Packagist auth0/login < 7.17.0
    Fixed in
    7.17.0· Vendor fix available
    Issue
    Session cookies of applications using the laravel-auth0 SDK configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. Am I Affected? You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using laravel-auth0 SDK with version <=7.16.0 2. laravel-auth0 SDK uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. Fix Upgrade Auth0/laravel-auth0 to v7.17.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. Acknowledgement Okta would like to thank Félix Charette for discovering this vulnerability.

    Recommended action: Upgrade to 7.17.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →