Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (auth0/login 7.21.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist auth0/login
- Affected
- >= 7.0.0, <= 7.20.0
- Fixed in
- 7.21.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmg6-246m-9g2v lists affected ranges: Packagist auth0/login >=7.0.0 <=7.20.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact In applications built with the Auth0 PHP SDK, cookies are encrypted with insufficient entropy, which may result in threat actors brute-forcing the encryption key and forging session cookies. Am I Affected? You are affected if you meet the following preconditions: - Applications using laravel-auth0 SDK, versions between 7.0.0 and 7.20.0 - Laravel-auth0 SDK using the Auth0-PHP SDK versions between 8.0.0 to 8.18.0. Resolution Upgrade Auth0/laravel-auth0 to version 7.21.0 or greater.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fmg6-246m-9g2v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-fmg6-246m-9g2v Advisory: Auth0 laravel-auth0 SDK has Insufficient Entropy in Cookie Encryption IDs: GHSA-fmg6-246m-9g2v Record: https://patchnext.com/advisories/ghsa-fmg6-246m-9g2v (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: auth0/login 7.21.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist auth0/login: affected >= 7.0.0, <= 7.20.0; fixed in 7.21.0 ## Suggested inspection (read-only) - Packagist auth0/login: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on auth0/login. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fmg6-246m-9g2v (GitHub-reviewed advisory GHSA-fmg6-246m-9g2v lists affected ranges: Packagist auth0/login >=7.0.0 <=7.20.0) Commands are suggestions: review each one before running it.
Loading voting…