Medium, CVSS 5.3PackagistPublished
amphp/http-server affected by HTTP/2 DDoS vulnerability
GHSA-8grv-jq2g-cfhw
- Affected
- Packagist amphp/http-server >= 3.0.0-beta.1, < 3.4.4; >= 2.0.0-rc1, < 2.1.10
- Fixed in
- 3.4.42.1.10· Vendor fix available
- Issue
- Versions of amphp/http-server prior to 3.4.4 for the 3.x release branch and prior to 2.1.10 for the 2.x release branch are vulnerable to the HTTP/2 "MadeYouReset" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506. In versions 3.4.4 and 2.1.10, stream reset protection has been refactored to account for the number of reset streams within a sliding time window. Note that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.
Recommended action: Upgrade to 3.4.4 or 2.1.10 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.