Skip to content

← Actionable
Medium, CVSS 5.3

amphp/http-server affected by HTTP/2 DDoS vulnerability

GHSA-8grv-jq2g-cfhw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (amphp/http-server 3.4.4, 2.1.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist amphp/http-server

    Affected
    >= 3.0.0-beta.1, < 3.4.4>= 2.0.0-rc1, < 2.1.10
    Fixed in
    3.4.4, 2.1.10

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Versions of amphp/http-server prior to 3.4.4 for the 3.x release branch and prior to 2.1.10 for the 2.x release branch are vulnerable to the HTTP/2 "MadeYouReset" DoS attack described by CVE-2025-8671 and https://kb.cert.org/vuls/id/767506. In versions 3.4.4 and 2.1.10, stream reset protection has been refactored to account for the number of reset streams within a sliding time window. Note that your application must expose HTTP/2 connections directly to be affected by this vulnerability. Servers behind a proxy using HTTP/1.x such as nginx are not affected.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8grv-jq2g-cfhw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-8grv-jq2g-cfhw

Advisory: amphp/http-server affected by HTTP/2 DDoS vulnerability
IDs: GHSA-8grv-jq2g-cfhw
Record: https://patchnext.com/advisories/ghsa-8grv-jq2g-cfhw (revision 1, source checked 26 Oct 2026, 14:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: amphp/http-server 3.4.4, 2.1.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist amphp/http-server: affected >= 3.0.0-beta.1, < 3.4.4; >= 2.0.0-rc1, < 2.1.10; fixed in 3.4.4, 2.1.10

## Suggested inspection (read-only)
- Packagist amphp/http-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on amphp/http-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8grv-jq2g-cfhw (GitHub-reviewed advisory GHSA-8grv-jq2g-cfhw lists affected ranges: Packagist amphp/http-server >=3.0.0-beta.1 =2.0.0-rc1 <2.1.10)

Commands are suggestions: review each one before running it.

Loading voting…