Skip to content

← Public intelligence

Packagist package

amphp/http-client

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.0PackagistPublished

    amphp/http-client Header leakage on cross-domain redirects

    GHSA-8jp9-mpv9-98rj

    Affected
    • Packagist amphp/http-client >= 4.0.0, < 4.4.0
    Fixed in
    4.4.0· Vendor fix available
    Issue
    amphp/http-client has a security weakness that might leak sensitive request headers from the initial request to the redirected host on cross-domain redirects, which were not removed correctly. Message::setHeaders does not replace the entire set of headers, but only operates on the headers matching the given array keys.

    Recommended action: Upgrade to 4.4.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →
  2. High, CVSS 8.2PackagistPublished

    amphp/http-client Denial of Service via HTTP/2 CONTINUATION Frames

    GHSA-w8gf-g2vq-j2f4

    Affected
    • Packagist amphp/http-client >= 4.0.0-rc10, <= 4.0.0
    Fixed in
    4.1.0-rc1· Vendor fix available
    Issue
    Early versions of amphp/http-client with HTTP/2 support (v4.0.0-rc10 to 4.0.0) will collect HTTP/2 CONTINUATION frames in an unbounded buffer and will not check the header size limit until it has received the ENDHEADERS flag, resulting in an OOM crash. Later versions of amphp/http-client (v4.1.0-rc1 and up) depend on amphp/http for HTTP/2 processing and will therefore need an updated version of amphp/http, see GHSA-qjfw-cvjf-f4fm. Acknowledgements Thank you to Bartek Nowotarski for reporting the vulnerability.

    Recommended action: Upgrade to 4.1.0-rc1 (pre-release) or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:github.comSource checked Evidence →