amphp/http-client Denial of Service via HTTP/2 CONTINUATION Frames
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (amphp/http-client 4.1.0-rc1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist amphp/http-client
- Affected
- >= 4.0.0-rc10, <= 4.0.0
- Fixed in
- 4.1.0-rc1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w8gf-g2vq-j2f4 lists affected ranges: Packagist amphp/http-client >=4.0.0-rc10 <=4.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Early versions of amphp/http-client with HTTP/2 support (v4.0.0-rc10 to 4.0.0) will collect HTTP/2 CONTINUATION frames in an unbounded buffer and will not check the header size limit until it has received the ENDHEADERS flag, resulting in an OOM crash. Later versions of amphp/http-client (v4.1.0-rc1 and up) depend on amphp/http for HTTP/2 processing and will therefore need an updated version of amphp/http, see GHSA-qjfw-cvjf-f4fm. Acknowledgements Thank you to Bartek Nowotarski for reporting the vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w8gf-g2vq-j2f4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-w8gf-g2vq-j2f4 Advisory: amphp/http-client Denial of Service via HTTP/2 CONTINUATION Frames IDs: GHSA-w8gf-g2vq-j2f4 Record: https://patchnext.com/advisories/ghsa-w8gf-g2vq-j2f4 (revision 1, source checked 26 Oct 2026, 14:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: amphp/http-client 4.1.0-rc1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist amphp/http-client: affected >= 4.0.0-rc10, <= 4.0.0; fixed in 4.1.0-rc1 ## Suggested inspection (read-only) - Packagist amphp/http-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on amphp/http-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w8gf-g2vq-j2f4 (GitHub-reviewed advisory GHSA-w8gf-g2vq-j2f4 lists affected ranges: Packagist amphp/http-client >=4.0.0-rc10 <=4.0.0) Commands are suggestions: review each one before running it.
Loading voting…